using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\d.*){9,}";
string input = @"123454576889
12fsdfsdf34343434dfgfg34545
12345678aaaaaaaaaa
12345aaaa6789
(123)567-89-10
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}