re = /(?:\d.*){9,}/m
str = '123454576889
12fsdfsdf34343434dfgfg34545
12345678aaaaaaaaaa
12345aaaa6789
(123)567-89-10
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end