import re
regex = re.compile(r"(?:\d.*){9,}", flags=re.MULTILINE)
test_str = ("123454576889\n"
"12fsdfsdf34343434dfgfg34545\n"
"12345678aaaaaaaaaa\n"
"12345aaaa6789\n"
"(123)567-89-10\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")