use strict;
my $str = '123454576889
12fsdfsdf34343434dfgfg34545
12345678aaaaaaaaaa
12345aaaa6789
(123)567-89-10
';
my $regex = qr/(?:\d.*){9,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}