// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\d.*){9,}").unwrap();
let string = "123454576889
12fsdfsdf34343434dfgfg34545
12345678aaaaaaaaaa
12345aaaa6789
(123)567-89-10
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}