import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^-A-Z0-9\\.\\/\\\\£]|\\A)\n"
+ "[\\.#]?\n"
+ "(\n"
+ "(?!\\d{2}[-\\\\/]\\d{2}[-\\\\/]\\d{2,4})\n"
+ "(?=[A-Z\\.\\/\\\\]*?\\d)\n"
+ "[-A-Z0-9\\.\\/\\\\]{3,10}[A-Z0-9]s?\n"
+ ")\n"
+ "(?:[^-A-Z0-9\\/\\\\]|\\Z)";
final String string = "1 x 100 Sterostrip Washproof dressings or nearest items. Code DR/546";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}