import re
regex = re.compile(r"""
(?:[^-A-Z0-9\.\/\\£]|\A)
[\.#]?
(
(?!\d{2}[-\\/]\d{2}[-\\/]\d{2,4})
(?=[A-Z\.\/\\]*?\d)
[-A-Z0-9\.\/\\]{3,10}[A-Z0-9]s?
)
(?:[^-A-Z0-9\/\\]|\Z)
""", flags=re.VERBOSE)
test_str = "1 x 100 Sterostrip Washproof dressings or nearest items. Code DR/546"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")