re = /(?:[^-A-Z0-9\.\/\\£]|\A)
[\.#]?
(
(?!\d{2}[-\\\/]\d{2}[-\\\/]\d{2,4})
(?=[A-Z\.\/\\]*?\d)
[-A-Z0-9\.\/\\]{3,10}[A-Z0-9]s?
)
(?:[^-A-Z0-9\/\\]|\Z)/x
str = '1 x 100 Sterostrip Washproof dressings or nearest items. Code DR/546'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end