#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]\d[A-Z]\d\s?[A-Z]\d$"
Local $sString = "A1A1A1" & @CRLF & _
"A1A1 A1" & @CRLF & _
"C2D3 P0" & @CRLF & _
"1A1A1A1" & @CRLF & _
"A1B2C3 D4E5F6" & @CRLF & _
"a1b2c3" & @CRLF & _
"a1b2c3 d4" & @CRLF & _
"a1b2xx c3" & @CRLF & _
"AABB DD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")