# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Z]\d[A-Z]\d\s?[A-Z]\d$"
test_str = ("A1A1A1\n"
"A1A1 A1\n"
"C2D3 P0\n"
"1A1A1A1\n"
"A1B2C3 D4E5F6\n"
"a1b2c3\n"
"a1b2c3 d4\n"
"a1b2xx c3\n"
"AABB DD")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.