using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]\d[A-Z]\d\s?[A-Z]\d$";
string input = @"A1A1A1
A1A1 A1
C2D3 P0
1A1A1A1
A1B2C3 D4E5F6
a1b2c3
a1b2c3 d4
a1b2xx c3
AABB DD";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}