use strict;
my $str = 'A1A1A1
A1A1 A1
C2D3 P0
1A1A1A1
A1B2C3 D4E5F6
a1b2c3
a1b2c3 d4
a1b2xx c3
AABB DD';
my $regex = qr/^[A-Z]\d[A-Z]\d\s?[A-Z]\d$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}