$re = '/^[A-Z]\d[A-Z]\d\s?[A-Z]\d$/m';
$str = 'A1A1A1
A1A1 A1
C2D3 P0
1A1A1A1
A1B2C3 D4E5F6
a1b2c3
a1b2c3 d4
a1b2xx c3
AABB DD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);