import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]\\d[A-Z]\\d\\s?[A-Z]\\d$";
final String string = "A1A1A1\n"
+ "A1A1 A1\n"
+ "C2D3 P0\n"
+ "1A1A1A1\n"
+ "A1B2C3 D4E5F6\n"
+ "a1b2c3\n"
+ "a1b2c3 d4\n"
+ "a1b2xx c3\n"
+ "AABB DD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}