using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<email_address>[\w\.-]+@[\w\.-]+\.[\w]+)";
string input = @"Name: Test Smith
Email: test@test.com
Phone: 123-456-7890
City: Dallas
State: TX
Zip: 75201
here is other text 2test@test.io
and some other stuff 94949494@stuff.co.in
If I write a paragragh with mutliple 99999@test.io and If I write a paragragh with mutliple 89999@test.mx.com and If I write a paragragh with mutliple 79999@test.com and If I write a paragragh with mutliple 69999@test.com and If I write a paragragh with mutliple 59999@test.com and
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}