import Foundation
let pattern = #"(?P<email_address>[\w\.-]+@[\w\.-]+\.[\w]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Name: Test Smith
Email: test@test.com
Phone: 123-456-7890
City: Dallas
State: TX
Zip: 75201
here is other text 2test@test.io
and some other stuff 94949494@stuff.co.in
If I write a paragragh with mutliple 99999@test.io and If I write a paragragh with mutliple 89999@test.mx.com and If I write a paragragh with mutliple 79999@test.com and If I write a paragragh with mutliple 69999@test.com and If I write a paragragh with mutliple 59999@test.com and
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)