import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<email_address>[\\w\\.-]+@[\\w\\.-]+\\.[\\w]+)";
final String string = "Name: Test Smith\n"
+ "Email: test@test.com\n"
+ "Phone: 123-456-7890\n"
+ "City: Dallas\n"
+ "State: TX\n"
+ "Zip: 75201\n"
+ "here is other text 2test@test.io\n"
+ "and some other stuff 94949494@stuff.co.in\n\n"
+ "If I write a paragragh with mutliple 99999@test.io and If I write a paragragh with mutliple 89999@test.mx.com and If I write a paragragh with mutliple 79999@test.com and If I write a paragragh with mutliple 69999@test.com and If I write a paragragh with mutliple 59999@test.com and \n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}