package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<email_address>[\w\.-]+@[\w\.-]+\.[\w]+)`)
var str = `Name: Test Smith
Email: test@test.com
Phone: 123-456-7890
City: Dallas
State: TX
Zip: 75201
here is other text 2test@test.io
and some other stuff 94949494@stuff.co.in
If I write a paragragh with mutliple 99999@test.io and If I write a paragragh with mutliple 89999@test.mx.com and If I write a paragragh with mutliple 79999@test.com and If I write a paragragh with mutliple 69999@test.com and If I write a paragragh with mutliple 59999@test.com and
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}