const regex = new RegExp('(?P<email_address>[\\w\\.-]+@[\\w\\.-]+\\.[\\w]+)', 'gm')
const str = `Name: Test Smith
Email: test@test.com
Phone: 123-456-7890
City: Dallas
State: TX
Zip: 75201
here is other text 2test@test.io
and some other stuff 94949494@stuff.co.in
If I write a paragragh with mutliple 99999@test.io and If I write a paragragh with mutliple 89999@test.mx.com and If I write a paragragh with mutliple 79999@test.com and If I write a paragragh with mutliple 69999@test.com and If I write a paragragh with mutliple 59999@test.com and
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}