# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\R{2})\R+/$1/gu;t' <<< "Dummy text
some more text
and
Dummy text
some more text"