#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(\R{2})\R+"
Local $sString = "Dummy text" & @CRLF & _
"" & @CRLF & _
"some more text" & @CRLF & _
"" & @CRLF & _
"and" & @CRLF & _
"Dummy text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"some more text"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)