use strict;
my $str = 'Dummy text
some more text
and
Dummy text
some more text';
my $regex = qr/(\R{2})\R+/up;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";