re = /(\R{2})\R+/
str = 'Dummy text
some more text
and
Dummy text
some more text'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result