package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\R{2})\R+`)
var str = `Dummy text
some more text
and
Dummy text
some more text`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}