import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " (-?) # sign\n"
+ " 0* # leading zeros\n"
+ " (\n"
+ " [0-9]+? .? [0-9]*? | # optional decimals\n"
+ " [0-9]*? .? [0-9]+? # optional wholes\n"
+ " )\n"
+ " 0* # trailing zeros\n"
+ "$\n"
+ " ";
final String string = "-0000100000.011100000000000000001000000000";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}