import re
regex = re.compile(r"""
^
(-?) # sign
0* # leading zeros
(
[0-9]+? .? [0-9]*? | # optional decimals
[0-9]*? .? [0-9]+? # optional wholes
)
0* # trailing zeros
$
""", flags=re.VERBOSE)
test_str = "-0000100000.011100000000000000001000000000"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")