const regex = /^
(-?) # sign
0* # leading zeros
(
[0-9]+? .? [0-9]*? | # optional decimals
[0-9]*? .? [0-9]+? # optional wholes
)
0* # trailing zeros
$
/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(-?) # sign
0* # leading zeros
(
[0-9]+? .? [0-9]*? | # optional decimals
[0-9]*? .? [0-9]+? # optional wholes
)
0* # trailing zeros
$
', '')
const str = `-0000100000.011100000000000000001000000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}