re = /^
(-?) # sign
0* # leading zeros
(
[0-9]+? .? [0-9]*? | # optional decimals
[0-9]*? .? [0-9]+? # optional wholes
)
0* # trailing zeros
$
/x
str = '-0000100000.011100000000000000001000000000'
# Print the match result
str.match(re) do |match|
puts match.to_s
end