// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)^
(-?) # sign
0* # leading zeros
(
[0-9]+? .? [0-9]*? | # optional decimals
[0-9]*? .? [0-9]+? # optional wholes
)
0* # trailing zeros
$
").unwrap();
let string = "-0000100000.011100000000000000001000000000";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}