#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[1-9]+\d*)|0)\.\d{2}$"
Local $sString = "// valid" & @CRLF & _
"0.00" & @CRLF & _
"0.99" & @CRLF & _
"10.00" & @CRLF & _
"999.99" & @CRLF & _
"1999999.99" & @CRLF & _
"" & @CRLF & _
"// invalid" & @CRLF & _
"1" & @CRLF & _
"1." & @CRLF & _
"1.9" & @CRLF & _
"1,99" & @CRLF & _
"1,999,999.99" & @CRLF & _
"1.999.999,99" & @CRLF & _
"01.99" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")