using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[1-9]+\d*)|0)\.\d{2}$";
string input = @"// valid
0.00
0.99
10.00
999.99
1999999.99
// invalid
1
1.
1.9
1,99
1,999,999.99
1.999.999,99
01.99
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}