re = /^(?:(?:[1-9]+\d*)|0)\.\d{2}$/m
str = '// valid
0.00
0.99
10.00
999.99
1999999.99
// invalid
1
1.
1.9
1,99
1,999,999.99
1.999.999,99
01.99
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end