import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[1-9]+\\d*)|0)\\.\\d{2}$";
final String string = "// valid\n"
+ "0.00\n"
+ "0.99\n"
+ "10.00\n"
+ "999.99\n"
+ "1999999.99\n\n"
+ "// invalid\n"
+ "1\n"
+ "1.\n"
+ "1.9\n"
+ "1,99\n"
+ "1,999,999.99\n"
+ "1.999.999,99\n"
+ "01.99\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}