const regex = /^(?:(?:[1-9]+\d*)|0)\.\d{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[1-9]+\\d*)|0)\\.\\d{2}$', 'gm')
const str = `// valid
0.00
0.99
10.00
999.99
1999999.99
// invalid
1
1.
1.9
1,99
1,999,999.99
1.999.999,99
01.99
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}