$re = '/^(?:(?:[1-9]+\d*)|0)\.\d{2}$/m';
$str = '// valid
0.00
0.99
10.00
999.99
1999999.99
// invalid
1
1.
1.9
1,99
1,999,999.99
1.999.999,99
01.99
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);