using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?= \d|\D+$|(?<!.*\D) )";
string input = @"SomeStreet 59A
Somestreet 59-65
6' SomeStreet 59
Somestreet 2.1
Somestreet 65 A/1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}