re = /(?= \d|\D+$|(?<!.*\D) )/m
str = 'SomeStreet 59A
Somestreet 59-65
6\' SomeStreet 59
Somestreet 2.1
Somestreet 65 A/1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end