const regex = /(?= \d|\D+$|(?<!.*\D) )/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?= \\d|\\D+$|(?<!.*\\D) )', 'gm')
const str = `SomeStreet 59A
Somestreet 59-65
6' SomeStreet 59
Somestreet 2.1
Somestreet 65 A/1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}