import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?= \\d|\\D+$|(?<!.*\\D) )";
final String string = "SomeStreet 59A\n"
+ "Somestreet 59-65\n"
+ "6' SomeStreet 59\n"
+ "Somestreet 2.1\n"
+ "Somestreet 65 A/1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}