#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(?:snooze|s) *\[( *\d\d\d\d\-\d{1,2}-\d\d(?: \d\d\d\d){0,1}) *\] *\]"
Local $sString = "[snooze [2021-12-25]]" & @CRLF & _
"[s [2021-12-25 1200]]" & @CRLF & _
"[snooze [2021-12-25 1234 ]]" & @CRLF & _
"[s [ 2021-1-25 1234 ]]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")