$re = '/\[(?:snooze|s) *\[( *\d\d\d\d\-\d{1,2}-\d\d(?: \d\d\d\d){0,1}) *\] *\]/m';
$str = '[snooze [2021-12-25]]
[s [2021-12-25 1200]]
[snooze [2021-12-25 1234 ]]
[s [ 2021-1-25 1234 ]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);