re = /\[(?:snooze|s) *\[( *\d\d\d\d\-\d{1,2}-\d\d(?: \d\d\d\d){0,1}) *\] *\]/m
str = '[snooze [2021-12-25]]
[s [2021-12-25 1200]]
[snooze [2021-12-25 1234 ]]
[s [ 2021-1-25 1234 ]]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end