import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?:snooze|s) *\\[( *\\d\\d\\d\\d\\-\\d{1,2}-\\d\\d(?: \\d\\d\\d\\d){0,1}) *\\] *\\]";
final String string = "[snooze [2021-12-25]]\n"
+ "[s [2021-12-25 1200]]\n"
+ "[snooze [2021-12-25 1234 ]]\n"
+ "[s [ 2021-1-25 1234 ]]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}