using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?:snooze|s) *\[( *\d\d\d\d\-\d{1,2}-\d\d(?: \d\d\d\d){0,1}) *\] *\]";
string input = @"[snooze [2021-12-25]]
[s [2021-12-25 1200]]
[snooze [2021-12-25 1234 ]]
[s [ 2021-1-25 1234 ]]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}