use strict;
my $str = '[snooze [2021-12-25]]
[s [2021-12-25 1200]]
[snooze [2021-12-25 1234 ]]
[s [ 2021-1-25 1234 ]]
';
my $regex = qr/\[(?:snooze|s) *\[( *\d\d\d\d\-\d{1,2}-\d\d(?: \d\d\d\d){0,1}) *\] *\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}