#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(?<SEPARATOR>[-.\/_]" & @CRLF & _
")([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(\k<SEPARATOR>)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$"
Local $sString = "MMDDYY" & @CRLF & _
"MMMM_DD_YY" & @CRLF & _
"DD.MM.YYY" & @CRLF & _
"PP.LL.MMMM" & @CRLF & _
"YYYYDD__MMM" & @CRLF & _
"MP.DD.YYYY" & @CRLF & _
"MMDDYYYY" & @CRLF & _
"MDDYY" & @CRLF & _
"OO.DD.YY" & @CRLF & _
"DD.DDD.YYYY" & @CRLF & _
"MMM.DYY.YYY" & @CRLF & _
"MM.DDDD.YYYY" & @CRLF & _
"DD.MD.YYYY" & @CRLF & _
"" & @CRLF & _
"MM.MM.YYYY" & @CRLF & _
"DD.DDD.DDD" & @CRLF & _
"D.MD.YYYY" & @CRLF & _
"MDYY"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")