# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"^(([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(?<SEPARATOR>[-.\/_]\n"
r")([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(\k<SEPARATOR>)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$")
test_str = ("MMDDYY\n"
"MMMM_DD_YY\n"
"DD.MM.YYY\n"
"PP.LL.MMMM\n"
"YYYYDD__MMM\n"
"MP.DD.YYYY\n"
"MMDDYYYY\n"
"MDDYY\n"
"OO.DD.YY\n"
"DD.DDD.YYYY\n"
"MMM.DYY.YYY\n"
"MM.DDDD.YYYY\n"
"DD.MD.YYYY\n\n"
"MM.MM.YYYY\n"
"DD.DDD.DDD\n"
"D.MD.YYYY\n"
"MDYY")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.