// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(?<SEPARATOR>[-.\/_]
)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(\k<SEPARATOR>)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$").unwrap();
let string = "MMDDYY
MMMM_DD_YY
DD.MM.YYY
PP.LL.MMMM
YYYYDD__MMM
MP.DD.YYYY
MMDDYYYY
MDDYY
OO.DD.YY
DD.DDD.YYYY
MMM.DYY.YYY
MM.DDDD.YYYY
DD.MD.YYYY
MM.MM.YYYY
DD.DDD.DDD
D.MD.YYYY
MDYY";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}