import Foundation
let pattern = #"""
^(([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(?<SEPARATOR>[-.\/_]
)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(\k<SEPARATOR>)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MMDDYY
MMMM_DD_YY
DD.MM.YYY
PP.LL.MMMM
YYYYDD__MMM
MP.DD.YYYY
MMDDYYYY
MDDYY
OO.DD.YY
DD.DDD.YYYY
MMM.DYY.YYY
MM.DDDD.YYYY
DD.MD.YYYY
MM.MM.YYYY
DD.DDD.DDD
D.MD.YYYY
MDYY
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)