using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(?<SEPARATOR>[-.\/_]
)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(\k<SEPARATOR>)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$";
string input = @"MMDDYY
MMMM_DD_YY
DD.MM.YYY
PP.LL.MMMM
YYYYDD__MMM
MP.DD.YYYY
MMDDYYYY
MDDYY
OO.DD.YY
DD.DDD.YYYY
MMM.DYY.YYY
MM.DDDD.YYYY
DD.MD.YYYY
MM.MM.YYYY
DD.DDD.DDD
D.MD.YYYY
MDYY";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}